28 lines
949 B
Nix
28 lines
949 B
Nix
{ config, pkgs, ... }:
|
||
|
||
{
|
||
#imports =
|
||
#[ # Include the results of the hardware scan.
|
||
#./hardware-configuration-current.nix
|
||
#./role-current.nix
|
||
#];
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
#system.stateVersion = "21.11"; # Did you read the comment?
|
||
|
||
boot.kernelPackages = pkgs.linuxPackages_latest;
|
||
boot.initrd.luks.devices.root = {
|
||
device = "/dev/nvme0n1p2";
|
||
preLVM = true;
|
||
};
|
||
nix.extraOptions = ''
|
||
experimental-features = nix-command flakes
|
||
'';
|
||
environment.systemPackages = with pkgs; [ vim git ];
|
||
}
|